<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en">
<![endif]-->
<!--[if !(IE 6) & !(IE 7) & !(IE 8)]><!-->
<html lang="en">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width" />
<title>We Will Never Forget Josiah Mwangi Kariuki (JM). | The Real Deal</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://deepcogitation.com/xmlrpc.php" />
<!--[if lt IE 9]>
<script src="https://s2.wp.com/wp-content/themes/pub/itheme2/js/html5.js" type="text/javascript"></script>
<![endif]-->

<meta name="google-site-verification" content="jfsj9edfwFbQhMXhDW0KqcoOrinVQb-lpADLvaAhguQ" />
<meta name="msvalidate.01" content="B4E70B486EFD43CDD86596CEE8F411BF" />

<!-- Async WordPress.com Remote Login -->
<script id="wpcom_remote_login_js">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</script>
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//deepcogitationdotcom.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="The Real Deal &raquo; Feed" href="https://deepcogitation.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Real Deal &raquo; Comments Feed" href="https://deepcogitation.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Real Deal &raquo; We Will Never Forget Josiah Mwangi Kariuki&nbsp;(JM). Comments Feed" href="https://deepcogitation.com/2020/03/09/we-will-never-forget-josiah-mwangi-kariuki-jm/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s0.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1582709031h&ver=5.4-RC1-47425"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0-1' href='https://s2.wp.com/_static/??-eJyllNtSxCAMhl9Iyh48rBeOz0LbiHE5DYStfXtTqLqua3XcG4ZAvuSfkCCHIDrvCBxJm0UwWaNLcgidtyJZNDCeWE2X0pU8j0UwiqAXwSc6sZYwg3tI8gUoqG4vivXN/d1XZzZbiJpvIsi7ZtusZJvR9LI1vuBtVHGUiUYDfwhTqKPsavSZhI7Y/zdEVIROp1/wp2yMSEggoMcJmMshr+9Wq9vr23sJB/ZnLjvq/eBqmoujvqsktGDQwcUBWZaubzwr7DGRPCAMPwbt/FyydbNZNWtRGqxy9aKposq7XiCtqjIc91ja6elSa05Nxuc2KJo8LGdSYMCy2xI2YK+BR4Bd5r0geF1GypC1bYiQkuDVYraCnjnX4vAwNampY1MSfjmpKErnCZlOH5tvMWsqGXIrsew3P7TGOcd9mYioxrL8pTTkw/xPnM9yhGjwgh+Kx8q7L4Z4Mgrj8o80tSdvdSnNpzlBj/ZhfbPbrnf3283u5Q1MnuFu?cssminify=yes' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify {
	text-align:justify;
}
</style>
<link rel='stylesheet' id='print-css-1-1' href='https://s2.wp.com/wp-content/mu-plugins/global-print/global-print.css?m=1465851035h&cssminify=yes' type='text/css' media='print' />
<link rel='stylesheet' id='all-css-2-1' href='https://s1.wp.com/_static/??-eJx9jtEOgjAMRX/IWcCJ8mD8ljHHqJZtoSXGv3cmEDEkPrVNzr098EzKxiAuCAyTSjR5DAzGCsbQmvG77S3zDlb4wnYTkWIUp9wNBYOfW0CfiqLWdQOeYmsyIy9yDCxG0EJLJjw2pSuHFFlURwZH4N6MuXiZ/1IcLeZfFH38PTYh6d2QdXo9+32A63Apj+eqOZS6Ku9vZApohQ==?cssminify=yes' type='text/css' media='all' />
<style id='jetpack-global-styles-frontend-style-inline-css'>
:root { --font-headings: unset; --font-base: unset; --font-headings-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --font-base-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif;}
</style>
<script>
var related_posts_js_options = {"post_heading":"h4"};
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJx9jMEOwjAMQ3+IruzABgfEt4wtVKmatDSNpv39ggSXHZAsWbae7dfikOekC4iPprdC3b7WRTn5f4AjDHVq0BHyD54zN+D2YSk/MYFTgToF6+zolY8cqStJA7L4CsnOFleytEOy1YPu/WXsb+dxGK5xB1+BRFU='></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s0.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1530132353h&cssminify=yes' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s2.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://deepcogitationdotcom.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='&quot;Those who killed this young man will not have&nbsp;peace&quot;' href='https://deepcogitation.com/2020/03/08/those-who-killed-this-young-man-will-not-have-peace/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://deepcogitation.com/2020/03/09/we-will-never-forget-josiah-mwangi-kariuki-jm/" />
<link rel='shortlink' href='https://wp.me/p2I8t1-2Jg' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fdeepcogitation.com%2F2020%2F03%2F09%2Fwe-will-never-forget-josiah-mwangi-kariuki-jm%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fdeepcogitation.com%2F2020%2F03%2F09%2Fwe-will-never-forget-josiah-mwangi-kariuki-jm%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="We Will Never Forget Josiah Mwangi Kariuki (JM)." />
<meta property="og:url" content="https://deepcogitation.com/2020/03/09/we-will-never-forget-josiah-mwangi-kariuki-jm/" />
<meta property="og:description" content="I can tell stories about JM day in campus every year I was there. Every year on March 2nd the students would be out there to fight for the nation on so many things. But I won&#8217;t go there today…" />
<meta property="article:published_time" content="2020-03-09T02:22:00+00:00" />
<meta property="article:modified_time" content="2020-03-09T04:07:45+00:00" />
<meta property="og:site_name" content="The Real Deal" />
<meta property="og:image" content="http://img.youtube.com/vi/a_iKO-Tiiq4/0.jpg" />
<meta property="og:image:secure_url" content="https://img.youtube.com/vi/a_iKO-Tiiq4/0.jpg" />
<meta property="og:image:width" content="200" />
<meta property="og:image:height" content="200" />
<meta property="og:locale" content="en_US" />
<meta property="og:video:type" content="text/html" />
<meta property="og:video" content="http://www.youtube.com/embed/a_iKO-Tiiq4" />
<meta property="og:video:secure_url" content="https://www.youtube.com/embed/a_iKO-Tiiq4" />
<meta name="twitter:creator" content="@deep_cogitation" />
<meta name="twitter:site" content="@deep_cogitation" />
<meta name="twitter:text:title" content="We Will Never Forget Josiah Mwangi Kariuki&nbsp;(JM)." />
<meta name="twitter:image" content="http://img.youtube.com/vi/a_iKO-Tiiq4/0.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />

<!-- End Jetpack Open Graph Tags -->
<link rel='openid.server' href='https://deepcogitation.com/?openidserver=1' />
<link rel='openid.delegate' href='https://deepcogitation.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://deepcogitation.com/osd.xml" title="The Real Deal" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<meta name="theme-color" content="#727272" />
<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>		<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<meta name="application-name" content="The Real Deal" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Fact Based Critical Examination and Analysis of Leadership, Governance, Politics and Societal Issues" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://deepcogitation.com/feed/;icon-uri=https://deepcogitationdotcom.files.wordpress.com/2017/10/cropped-sankofa-dc.png?w=16" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="description" content="I can tell stories about JM day in campus every year I was there. Every year on March 2nd the students would be out there to fight for the nation on so many things. But I won&#039;t go there today. Here is JM. https://www.youtube.com/watch?v=a_iKO-Tiiq4&amp;feature=emb_rel_end" />
	<style type="text/css">
			#site-title,
		#site-description {
			position: absolute !important;
			clip: rect(1px 1px 1px 1px); /* IE6, IE7 */
			clip: rect(1px, 1px, 1px, 1px);
		}
		</style>
	<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #727272; background-image: url("https://deepcogitationdotcom.files.wordpress.com/2019/07/dc-bg-1.png"); background-position: center top; background-size: contain; background-repeat: no-repeat; background-attachment: fixed; }
</style>
	<link rel="amphtml" href="https://deepcogitation.com/2020/03/09/we-will-never-forget-josiah-mwangi-kariuki-jm/amp/"><link rel="icon" href="https://deepcogitationdotcom.files.wordpress.com/2017/10/cropped-sankofa-dc.png?w=32" sizes="32x32" />
<link rel="icon" href="https://deepcogitationdotcom.files.wordpress.com/2017/10/cropped-sankofa-dc.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://deepcogitationdotcom.files.wordpress.com/2017/10/cropped-sankofa-dc.png?w=180" />
<meta name="msapplication-TileImage" content="https://deepcogitationdotcom.files.wordpress.com/2017/10/cropped-sankofa-dc.png?w=244" />
</head>

<body class="post-template-default single single-post postid-10494 single-format-standard custom-background customizer-styles-applied highlander-enabled highlander-light">
<div id="page" class="hfeed">
	<header id="masthead" role="banner">
		<hgroup>
			<h1 id="site-title"><a href="https://deepcogitation.com/" title="The Real Deal" rel="home">The Real Deal</a></h1>
			<h2 id="site-description">Fact Based Critical Examination and Analysis of Leadership, Governance, Politics and Societal Issues</h2>
		</hgroup>

					<a href="https://deepcogitation.com/">
				<img id="custom-header-image" src="https://deepcogitationdotcom.files.wordpress.com/2012/09/therealdealhead1.png" width="978" height="288" alt="" />
			</a>
				<nav id="access" role="navigation">
			<h1 class="assistive-text section-heading">Main menu</h1>
			<div class="assistive-text skip-link"><a href="#content" title="Skip to content">Skip to content</a></div>

			<div class="menu"><ul>
<li ><a href="https://deepcogitation.com/">Home</a></li><li class="page_item page-item-2"><a href="https://deepcogitation.com/about/">About</a></li>
<li class="page_item page-item-9227"><a href="https://deepcogitation.com/announcement/">Announcement</a></li>
<li class="page_item page-item-99"><a href="https://deepcogitation.com/archives/">Archives</a></li>
<li class="page_item page-item-880"><a href="https://deepcogitation.com/contact/">Contact</a></li>
<li class="page_item page-item-9552 page_item_has_children"><a href="https://deepcogitation.com/leisure/">Leisure</a>
<ul class='children'>
	<li class="page_item page-item-15"><a href="https://deepcogitation.com/leisure/music/">Music</a></li>
	<li class="page_item page-item-120"><a href="https://deepcogitation.com/leisure/sports/">Sports</a></li>
</ul>
</li>
<li class="page_item page-item-9654"><a href="https://deepcogitation.com/science-tech-news/">Science &amp; Tech&nbsp;News</a></li>
<li class="page_item page-item-9206"><a href="https://deepcogitation.com/top-news/">World News *NEW*</a></li>
<li class="page_item page-item-245 page_item_has_children"><a href="https://deepcogitation.com/xclusive/">Xclusive</a>
<ul class='children'>
	<li class="page_item page-item-35"><a href="https://deepcogitation.com/xclusive/blog-admin-features/">Blog Admin Features</a></li>
	<li class="page_item page-item-73"><a href="https://deepcogitation.com/xclusive/blog-development/">Blog Development</a></li>
	<li class="page_item page-item-769"><a href="https://deepcogitation.com/xclusive/contributors/">Contributors</a></li>
	<li class="page_item page-item-322 page_item_has_children"><a href="https://deepcogitation.com/xclusive/elections-watch/">Elections</a>
	<ul class='children'>
		<li class="page_item page-item-324"><a href="https://deepcogitation.com/xclusive/elections-watch/calendar/">Election Calendar</a></li>
		<li class="page_item page-item-1309"><a href="https://deepcogitation.com/xclusive/elections-watch/voter-register-2012/">Voter Register &#8211; (Provisional)&nbsp;2012</a></li>
	</ul>
</li>
	<li class="page_item page-item-176"><a href="https://deepcogitation.com/xclusive/kenya/">Kenya</a></li>
	<li class="page_item page-item-19"><a href="https://deepcogitation.com/xclusive/members-2/">Members</a></li>
	<li class="page_item page-item-537"><a href="https://deepcogitation.com/xclusive/members/">Members</a></li>
	<li class="page_item page-item-27"><a href="https://deepcogitation.com/xclusive/sub-private-page/">Membership Outreach</a></li>
	<li class="page_item page-item-386"><a href="https://deepcogitation.com/xclusive/politically-instigated-violence/">Politically Instigated Violence</a></li>
</ul>
</li>
</ul></div>
		</nav><!-- #access -->
	</header><!-- #masthead -->

	<div id="main">
		<div id="primary">
			<div id="content" role="main">

			
					<nav id="nav-above">
		<h1 class="assistive-text section-heading">Post navigation</h1>

	
		<div class="nav-previous"><a href="https://deepcogitation.com/2020/03/08/those-who-killed-this-young-man-will-not-have-peace/" rel="prev"><span class="meta-nav">&larr;</span> &quot;Those who killed this young man will not have&nbsp;peace&quot;</a></div>		
	
	</nav><!-- #nav-above -->
	
				
<article id="post-10494" class="post-10494 post type-post status-publish format-standard hentry category-kenya">
	<header class="entry-header">
		
		<div class="post-date">
					<span class="month">Mar</span>
			<span class="day">9</span>
			<span class="year">2020</span>
				</div>

				
							<h1 class="entry-title">
									We Will Never Forget Josiah Mwangi Kariuki&nbsp;(JM).							</h1>
			</header><!-- .entry-header -->

		<div class="entry-content">
		
<p>I can tell stories about JM day in campus every year I was there. Every year on March 2nd the students would be out there to fight for the nation on so many things. But I won&#8217;t go there today.</p>



<p>Here is JM.</p>



<figure class="wp-block-embed-youtube wp-block-embed is-type-rich wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='593' height='334' src='https://www.youtube.com/embed/a_iKO-Tiiq4?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span>
</div></figure>
<div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://deepcogitation.com/2020/03/09/we-will-never-forget-josiah-mwangi-kariuki-jm/" data-text="We Will Never Forget Josiah Mwangi Kariuki (JM)." data-via="deep_cogitation" data-related="wordpressdotcom">Tweet</a></li><li class="share-facebook"><div class="fb-share-button" data-href="https://deepcogitation.com/2020/03/09/we-will-never-forget-josiah-mwangi-kariuki-jm/" data-layout="button_count"></div></li><li class="share-linkedin"><div class="linkedin_button"><script type="in/share" data-url="https://deepcogitation.com/2020/03/09/we-will-never-forget-josiah-mwangi-kariuki-jm/" data-counter="right"></script></div></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button" href="https://deepcogitation.com/2020/03/09/we-will-never-forget-josiah-mwangi-kariuki-jm/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button" href="https://deepcogitation.com/2020/03/09/we-will-never-forget-josiah-mwangi-kariuki-jm/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-40071655-10494-5e65d819c3538' data-src='//widgets.wp.com/likes/index.html?ver=20190321#blog_id=40071655&amp;post_id=10494&amp;origin=deepcogitationdotcom.wordpress.com&amp;obj_id=40071655-10494-5e65d819c3538&amp;domain=deepcogitation.com' data-name='like-post-frame-40071655-10494-5e65d819c3538'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div>			</div><!-- .entry-content -->
	
	<footer class="entry-meta">
					By adongoogony
						<span class="sep"> &#149; </span>
			<span class="cat-links">
				Posted in <a href="https://deepcogitation.com/category/kenya/" rel="category tag">kenya</a>			</span>
			
			
					
				<div class="comments-link">
			<a href="https://deepcogitation.com/2020/03/09/we-will-never-forget-josiah-mwangi-kariuki-jm/#respond"><span class="no-replies">0</span></a>		</div>
			</footer><!-- #entry-meta -->
</article><!-- #post-10494 -->

					<nav id="nav-below">
		<h1 class="assistive-text section-heading">Post navigation</h1>

	
		<div class="nav-previous"><a href="https://deepcogitation.com/2020/03/08/those-who-killed-this-young-man-will-not-have-peace/" rel="prev"><span class="meta-nav">&larr;</span> &quot;Those who killed this young man will not have&nbsp;peace&quot;</a></div>		
	
	</nav><!-- #nav-below -->
	
					<div id="comments">
	
	
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">What Say You Now? <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/03/09/we-will-never-forget-josiah-mwangi-kariuki-jm/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://deepcogitation.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="e17f7239de" /><input type="hidden" name="_wp_http_referer" value="/2020/03/09/we-will-never-forget-josiah-mwangi-kariuki-jm/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">
	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" class="nascar-signin-link"
                   title="Login via Guest">
									</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" class="nascar-signin-link"
                   title="Login via WordPress.com">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg>				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" class="nascar-signin-link"
                   title="Login via Twitter">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg>				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" class="nascar-signin-link"
                   title="Login via Facebook">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg>				</a>
			</li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
			
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
						<p class="comment-form-posting-as pa-wordpress">
			<strong></strong>
			You are commenting using your WordPress.com account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25" alt="Google photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
						<p class="comment-form-posting-as pa-googleplus">
			<strong></strong>
			You are commenting using your Google account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" x="0px" y="0px" viewBox="0 0 60 60" ><path fill="#519bf7" d="M56.3,30c0,-1.6 -0.2,-3.4 -0.6,-5h-3.1H42.2H30v10.6h14.8C44,39.3 42,42 39.1,43.9l8.8,6.8C53,46 56.3,39 56.3,30z" /><path fill="#3db366" d="M30,57.5c6.7,0 13.1,-2.4 17.9,-6.8l-8.8,-6.8c-2.5,1.6 -5.6,2.4 -9.1,2.4c-7.2,0 -13.3,-4.7 -15.4,-11.2l-9.3,7.1C9.8,51.3 19.1,57.5 30,57.5z" /><path fill="#fdc600" d="M5.3,42.2l9.3,-7.1c-0.5,-1.6 -0.8,-3.3 -0.8,-5.1s0.3,-3.5 0.8,-5.1l-9.3,-7.1C3.5,21.5 2.5,25.6 2.5,30S3.5,38.5 5.3,42.2z" /><path fill="#f15b44" d="M40.1,17.4l8,-8C43.3,5.1 37,2.5 30,2.5C19.1,2.5 9.8,8.7 5.3,17.8l9.3,7.1c2.1,-6.5 8.2,-11.1 15.4,-11.1C33.9,13.7 37.4,15.1 40.1,17.4z" /></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
						<p class="comment-form-posting-as pa-twitter">
			<strong></strong>
			You are commenting using your Twitter account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
						<p class="comment-form-posting-as pa-facebook">
			<strong></strong>
			You are commenting using your Facebook account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p><p class="post-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog"  style="display: inline;">Notify me of new posts via email.</label></p></div>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='10494' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="0a3e420df4" /></p>
<input type="hidden" name="genseq" value="1583732761" />
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="10"/></p></form>	</div><!-- #respond -->
	<div style="clear: both"></div>
</div><!-- #comments -->

			
			</div><!-- #content -->
		</div><!-- #primary -->

		<div id="secondary" class="widget-area" role="complementary">
					<aside id="text-4" class="widget widget_text"><h1 class="widget-title">*Quicklinks* &#8211; logged in users only</h1>			<div class="textwidget"><p>--------------------------------------------------posts<br />
<a href="https://deepcogitationdotcom.wordpress.com/wp-admin/edit.php">My Posts  </a>       |     <a href="https://deepcogitationdotcom.wordpress.com/archives">All Posts  </a>       |     <a href="/wp-admin/post-new.php">Create New Post </a><br />
-------------------------------------------comments<br />
 <a href="https://deepcogitationdotcom.wordpress.com/wp-admin/edit-comments.php"> All Comments  </a>      |     <a href="https://deepcogitationdotcom.wordpress.com/wp-admin/index.php?page=my-comments"> My Comments </a><br />
-------------------------------------------------profile<br />
<a href="/wp-admin/users.php?page=grofiles-editor"> Change My Profile </a><br />
------------------------------------------------replies<br />
<a href="http://wordpress.com/#!/notifications/"> Replies to my posts/comments </a><br />
---------------------------------------------log in/out<br />
<a href="/wp-login.php"> Login /  Logout </a><br />
<span style="color:#800000;"><strong>-----------------------------------------------contact<br />
<a href="https://deepcogitation.com/contact/"> Contact Blog-Admin </a></strong></span></p>
</div>
		</aside><aside id="search-2" class="widget widget_search">	<form method="get" id="searchform" action="https://deepcogitation.com/">
		<label for="s" class="assistive-text">Search</label>
		<input type="text" class="field" name="s" id="s" placeholder="Search &hellip;" />
		<input type="submit" class="submit" name="submit" id="searchsubmit" value="Search" />
	</form>
</aside><aside id="top-posts-2" class="widget widget_top-posts"><h1 class="widget-title">Most Read</h1><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://deepcogitation.com/2020/03/07/from-kumi-tena-to-icc-tena-this-is-turning-into-chaos-for-dp-ruto/" title="From Kumi Tena To ICC Tena. This Is Turning Into Ruto&#039;s Worst Nightmare. This Time He is Alone. Good Luck." class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="https://lh3.googleusercontent.com/JHiwssHf_rtPJ4EqIiB_GSLDOSemj4E-SmcjupuCUMRVkGzudSkx2ZBa_P_wN5j7iCEnP6K6h4gNmFJJFamlCfR6Fe_gPg=s750" alt="From Kumi Tena To ICC Tena. This Is Turning Into Ruto&#039;s Worst Nightmare. This Time He is Alone. Good Luck." data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://deepcogitation.com/2020/03/07/from-kumi-tena-to-icc-tena-this-is-turning-into-chaos-for-dp-ruto/" title="From Kumi Tena To ICC Tena. This Is Turning Into Ruto&#039;s Worst Nightmare. This Time He is Alone. Good Luck." class="bump-view" data-bump-view="tp">From Kumi Tena To ICC Tena. This Is Turning Into Ruto&#039;s Worst Nightmare. This Time He is Alone. Good Luck.</a>
							</div>
													</li>
										<li>
						<a href="https://deepcogitation.com/2020/03/08/those-who-killed-this-young-man-will-not-have-peace/" title="&quot;Those who killed this young man will not have peace&quot;" class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="https://deepcogitationdotcom.files.wordpress.com/2017/10/cropped-sankofa-dc.png?w=40" alt="&quot;Those who killed this young man will not have peace&quot;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://deepcogitation.com/2020/03/08/those-who-killed-this-young-man-will-not-have-peace/" title="&quot;Those who killed this young man will not have peace&quot;" class="bump-view" data-bump-view="tp">&quot;Those who killed this young man will not have peace&quot;</a>
							</div>
													</li>
										<li>
						<a href="https://deepcogitation.com/2020/02/25/always-angry-ruto-can-he-be-a-president-of-our-jamhuri/" title="Always Angry Ruto. Can he be a president of our jamhuri?" class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="https://lh3.googleusercontent.com/Jp1qQKKaAUdFAdNOB50lnbA0g4v4ivkswfitlib764QBoXXoLWnzH3mUjQHWKvPm4hYx4MEHwapVLn9ace-lK_EKOZp1hg=s750" alt="Always Angry Ruto. Can he be a president of our jamhuri?" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://deepcogitation.com/2020/02/25/always-angry-ruto-can-he-be-a-president-of-our-jamhuri/" title="Always Angry Ruto. Can he be a president of our jamhuri?" class="bump-view" data-bump-view="tp">Always Angry Ruto. Can he be a president of our jamhuri?</a>
							</div>
													</li>
										<li>
						<a href="https://deepcogitation.com/2019/03/09/international-womens-day-greetings/" title="International Women&#039;s Day: Greetings Everyone." class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="https://deepcogitationdotcom.files.wordpress.com/2017/10/cropped-sankofa-dc.png?w=40" alt="International Women&#039;s Day: Greetings Everyone." data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://deepcogitation.com/2019/03/09/international-womens-day-greetings/" title="International Women&#039;s Day: Greetings Everyone." class="bump-view" data-bump-view="tp">International Women&#039;s Day: Greetings Everyone.</a>
							</div>
													</li>
										<li>
						<a href="https://deepcogitation.com/top-news/" title="World News *NEW*" class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="https://deepcogitationdotcom.files.wordpress.com/2017/10/cropped-sankofa-dc.png?w=40" alt="World News *NEW*" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://deepcogitation.com/top-news/" title="World News *NEW*" class="bump-view" data-bump-view="tp">World News *NEW*</a>
							</div>
													</li>
										<li>
						<a href="https://deepcogitation.com/2013/01/10/the-resurgence-of-the-ngoroko-state-in-kenya/" title="The Resurgence of the “Ngoroko” State in Kenya" class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="https://i0.wp.com/www.thepeople.co.ke/image/gallery/bad+year+for+police+officers.png?resize=40%2C40" alt="The Resurgence of the “Ngoroko” State in Kenya" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://deepcogitation.com/2013/01/10/the-resurgence-of-the-ngoroko-state-in-kenya/" title="The Resurgence of the “Ngoroko” State in Kenya" class="bump-view" data-bump-view="tp">The Resurgence of the “Ngoroko” State in Kenya</a>
							</div>
													</li>
					</ul>
</aside>		<aside id="recent-posts-2" class="widget widget_recent_entries">		<h1 class="widget-title">Recently Published</h1>		<ul>
											<li>
					<a href="https://deepcogitation.com/2020/03/09/we-will-never-forget-josiah-mwangi-kariuki-jm/" aria-current="page">We Will Never Forget Josiah Mwangi Kariuki&nbsp;(JM).</a>
									</li>
											<li>
					<a href="https://deepcogitation.com/2020/03/08/those-who-killed-this-young-man-will-not-have-peace/">&quot;Those who killed this young man will not have&nbsp;peace&quot;</a>
									</li>
											<li>
					<a href="https://deepcogitation.com/2020/03/07/from-kumi-tena-to-icc-tena-this-is-turning-into-chaos-for-dp-ruto/">From Kumi Tena To ICC Tena. This Is Turning Into Ruto&#039;s Worst Nightmare. This Time He is Alone. Good&nbsp;Luck.</a>
									</li>
											<li>
					<a href="https://deepcogitation.com/2020/03/06/d-p-ruto-ranted-this-was-a-desperate-propaganda-by-his-enemies-now-have-a-cold-blooded-murder-in-our-hands-what-gives/">D.P Ruto ranted this was a desperate propaganda by his enemies. Now we have a &quot;cold blooded murder&quot; in our hands. What&nbsp;gives?</a>
									</li>
											<li>
					<a href="https://deepcogitation.com/2020/03/06/d-p-ruto-raved-that-this-whole-case-was-propaganda-by-desperate-forces-now-we-have-cold-blooded-murder-in-our-hands-what-gives/">D.P Ruto raved that this whole case was propaganda by desperate forces. Now we have &quot;cold blooded murder&quot; in our hands. What&nbsp;gives.</a>
									</li>
											<li>
					<a href="https://deepcogitation.com/2020/03/04/the-captain-is-in-the-house-oh-dear/">The Captain is in the house. Oh&nbsp;Dear.</a>
									</li>
											<li>
					<a href="https://deepcogitation.com/2020/03/04/gangsters-v-hustlers/">Gangsters V Hustlers.</a>
									</li>
											<li>
					<a href="https://deepcogitation.com/2020/03/03/i-need-to-talk-to-david-murathe-about-this/">I need to talk to David Murathe about&nbsp;this.</a>
									</li>
					</ul>
		</aside><aside id="recent-comments-3" class="widget widget_recent_comments"><h1 class="widget-title">Recent Comments</h1>				<table class="recentcommentsavatar" cellspacing="0" cellpadding="0" border="0">
					<tr><td title="adongoogony" class="recentcommentsavatartop" style="height:16px; width:16px;"><img alt='' src='https://2.gravatar.com/avatar/e21ce7d4fa9290d645b5419b9731f842?s=16&#038;d=https%3A%2F%2F2.gravatar.com%2Favatar%2Fad516503a11cd5ca435acc9bb6523536%3Fs%3D16&#038;r=G' class='avatar avatar-16' height='16' width='16' /></td><td class="recentcommentstexttop" style="">adongoogony on <a href="https://deepcogitation.com/2020/03/08/those-who-killed-this-young-man-will-not-have-peace/comment-page-1/#comment-52738">&quot;Those who killed this yo&hellip;</a></td></tr><tr><td title="adongoogony" class="recentcommentsavatarend" style="height:16px; width:16px;"><img alt='' src='https://2.gravatar.com/avatar/e21ce7d4fa9290d645b5419b9731f842?s=16&#038;d=https%3A%2F%2F2.gravatar.com%2Favatar%2Fad516503a11cd5ca435acc9bb6523536%3Fs%3D16&#038;r=G' class='avatar avatar-16' height='16' width='16' /></td><td class="recentcommentstextend" style="">adongoogony on <a href="https://deepcogitation.com/2020/02/29/bbi-presentation-to-bbi-by-oduor-ongwen-on-feb-26-2020/comment-page-1/#comment-52517">ODM Presentation to BBI on Feb&hellip;</a></td></tr><tr><td title="einstein" class="recentcommentsavatarend" style="height:16px; width:16px;"><img alt='' src='https://0.gravatar.com/avatar/30a766b0476aee54c8fba7fed01f40bc?s=16&#038;d=https%3A%2F%2F0.gravatar.com%2Favatar%2Fad516503a11cd5ca435acc9bb6523536%3Fs%3D16&#038;r=G' class='avatar avatar-16' height='16' width='16' /></td><td class="recentcommentstextend" style="">einstein on <a href="https://deepcogitation.com/2020/02/25/always-angry-ruto-can-he-be-a-president-of-our-jamhuri/comment-page-1/#comment-52497">Always Angry Ruto. Can he be a&hellip;</a></td></tr><tr><td title="adongoogony" class="recentcommentsavatarend" style="height:16px; width:16px;"><img alt='' src='https://2.gravatar.com/avatar/e21ce7d4fa9290d645b5419b9731f842?s=16&#038;d=https%3A%2F%2F2.gravatar.com%2Favatar%2Fad516503a11cd5ca435acc9bb6523536%3Fs%3D16&#038;r=G' class='avatar avatar-16' height='16' width='16' /></td><td class="recentcommentstextend" style="">adongoogony on <a href="https://deepcogitation.com/2020/02/16/ruto-and-echesa-what-is-going-on/comment-page-1/#comment-52232">Ruto and Echesa: What is going&hellip;</a></td></tr><tr><td title="adongoogony" class="recentcommentsavatarend" style="height:16px; width:16px;"><img alt='' src='https://2.gravatar.com/avatar/e21ce7d4fa9290d645b5419b9731f842?s=16&#038;d=https%3A%2F%2F2.gravatar.com%2Favatar%2Fad516503a11cd5ca435acc9bb6523536%3Fs%3D16&#038;r=G' class='avatar avatar-16' height='16' width='16' /></td><td class="recentcommentstextend" style="">adongoogony on <a href="https://deepcogitation.com/2020/02/16/ruto-and-echesa-what-is-going-on/comment-page-1/#comment-52171">Ruto and Echesa: What is going&hellip;</a></td></tr><tr><td title="adongoogony" class="recentcommentsavatarend" style="height:16px; width:16px;"><img alt='' src='https://2.gravatar.com/avatar/e21ce7d4fa9290d645b5419b9731f842?s=16&#038;d=https%3A%2F%2F2.gravatar.com%2Favatar%2Fad516503a11cd5ca435acc9bb6523536%3Fs%3D16&#038;r=G' class='avatar avatar-16' height='16' width='16' /></td><td class="recentcommentstextend" style="">adongoogony on <a href="https://deepcogitation.com/2020/02/16/ruto-and-echesa-what-is-going-on/comment-page-1/#comment-52166">Ruto and Echesa: What is going&hellip;</a></td></tr><tr><td title="adongoogony" class="recentcommentsavatarend" style="height:16px; width:16px;"><img alt='' src='https://2.gravatar.com/avatar/e21ce7d4fa9290d645b5419b9731f842?s=16&#038;d=https%3A%2F%2F2.gravatar.com%2Favatar%2Fad516503a11cd5ca435acc9bb6523536%3Fs%3D16&#038;r=G' class='avatar avatar-16' height='16' width='16' /></td><td class="recentcommentstextend" style="">adongoogony on <a href="https://deepcogitation.com/2020/02/16/ruto-and-echesa-what-is-going-on/comment-page-1/#comment-52162">Ruto and Echesa: What is going&hellip;</a></td></tr><tr><td title="adongoogony" class="recentcommentsavatarend" style="height:16px; width:16px;"><img alt='' src='https://2.gravatar.com/avatar/e21ce7d4fa9290d645b5419b9731f842?s=16&#038;d=https%3A%2F%2F2.gravatar.com%2Favatar%2Fad516503a11cd5ca435acc9bb6523536%3Fs%3D16&#038;r=G' class='avatar avatar-16' height='16' width='16' /></td><td class="recentcommentstextend" style="">adongoogony on <a href="https://deepcogitation.com/2020/02/16/ruto-and-echesa-what-is-going-on/comment-page-1/#comment-52160">Ruto and Echesa: What is going&hellip;</a></td></tr><tr><td title="adongoogony" class="recentcommentsavatarend" style="height:16px; width:16px;"><img alt='' src='https://2.gravatar.com/avatar/e21ce7d4fa9290d645b5419b9731f842?s=16&#038;d=https%3A%2F%2F2.gravatar.com%2Favatar%2Fad516503a11cd5ca435acc9bb6523536%3Fs%3D16&#038;r=G' class='avatar avatar-16' height='16' width='16' /></td><td class="recentcommentstextend" style="">adongoogony on <a href="https://deepcogitation.com/2020/02/09/just-beautiful-the-blues/comment-page-1/#comment-51929">Just Beautiful. The&nbsp;Blues</a></td></tr><tr><td title="adongoogony" class="recentcommentsavatarend" style="height:16px; width:16px;"><img alt='' src='https://2.gravatar.com/avatar/e21ce7d4fa9290d645b5419b9731f842?s=16&#038;d=https%3A%2F%2F2.gravatar.com%2Favatar%2Fad516503a11cd5ca435acc9bb6523536%3Fs%3D16&#038;r=G' class='avatar avatar-16' height='16' width='16' /></td><td class="recentcommentstextend" style="">adongoogony on <a href="https://deepcogitation.com/2020/02/04/kenyas-former-president-daniel-arap-moi-is-dead/comment-page-1/#comment-51828">Kenya’s former President Danie&hellip;</a></td></tr><tr><td title="adongoogony" class="recentcommentsavatarend" style="height:16px; width:16px;"><img alt='' src='https://2.gravatar.com/avatar/e21ce7d4fa9290d645b5419b9731f842?s=16&#038;d=https%3A%2F%2F2.gravatar.com%2Favatar%2Fad516503a11cd5ca435acc9bb6523536%3Fs%3D16&#038;r=G' class='avatar avatar-16' height='16' width='16' /></td><td class="recentcommentstextend" style="">adongoogony on <a href="https://deepcogitation.com/2020/02/04/kenyas-former-president-daniel-arap-moi-is-dead/comment-page-1/#comment-51779">Kenya’s former President Danie&hellip;</a></td></tr><tr><td title="adongoogony" class="recentcommentsavatarend" style="height:16px; width:16px;"><img alt='' src='https://2.gravatar.com/avatar/e21ce7d4fa9290d645b5419b9731f842?s=16&#038;d=https%3A%2F%2F2.gravatar.com%2Favatar%2Fad516503a11cd5ca435acc9bb6523536%3Fs%3D16&#038;r=G' class='avatar avatar-16' height='16' width='16' /></td><td class="recentcommentstextend" style="">adongoogony on <a href="https://deepcogitation.com/2020/01/27/do-we-have-kobe/comment-page-1/#comment-51672">Do We Have&nbsp;Kobe?</a></td></tr><tr><td title="adongoogony" class="recentcommentsavatarend" style="height:16px; width:16px;"><img alt='' src='https://2.gravatar.com/avatar/e21ce7d4fa9290d645b5419b9731f842?s=16&#038;d=https%3A%2F%2F2.gravatar.com%2Favatar%2Fad516503a11cd5ca435acc9bb6523536%3Fs%3D16&#038;r=G' class='avatar avatar-16' height='16' width='16' /></td><td class="recentcommentstextend" style="">adongoogony on <a href="https://deepcogitation.com/2020/01/14/bbi-is-going-on/comment-page-1/#comment-51641">BBI Is Going&nbsp;On</a></td></tr><tr><td title="adongoogony" class="recentcommentsavatarend" style="height:16px; width:16px;"><img alt='' src='https://2.gravatar.com/avatar/e21ce7d4fa9290d645b5419b9731f842?s=16&#038;d=https%3A%2F%2F2.gravatar.com%2Favatar%2Fad516503a11cd5ca435acc9bb6523536%3Fs%3D16&#038;r=G' class='avatar avatar-16' height='16' width='16' /></td><td class="recentcommentstextend" style="">adongoogony on <a href="https://deepcogitation.com/2020/01/27/do-we-have-kobe/comment-page-1/#comment-51638">Do We Have&nbsp;Kobe?</a></td></tr>				</table>
				</aside><aside id="archives-2" class="widget widget_archive"><h1 class="widget-title">Archives</h1>		<label class="screen-reader-text" for="archives-dropdown-2">Archives</label>
		<select id="archives-dropdown-2" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://deepcogitation.com/2020/03/'> March 2020 </option>
	<option value='https://deepcogitation.com/2020/02/'> February 2020 </option>
	<option value='https://deepcogitation.com/2020/01/'> January 2020 </option>
	<option value='https://deepcogitation.com/2019/12/'> December 2019 </option>
	<option value='https://deepcogitation.com/2019/11/'> November 2019 </option>
	<option value='https://deepcogitation.com/2019/10/'> October 2019 </option>
	<option value='https://deepcogitation.com/2019/09/'> September 2019 </option>
	<option value='https://deepcogitation.com/2019/08/'> August 2019 </option>
	<option value='https://deepcogitation.com/2019/07/'> July 2019 </option>
	<option value='https://deepcogitation.com/2019/06/'> June 2019 </option>
	<option value='https://deepcogitation.com/2019/05/'> May 2019 </option>
	<option value='https://deepcogitation.com/2019/04/'> April 2019 </option>
	<option value='https://deepcogitation.com/2019/03/'> March 2019 </option>
	<option value='https://deepcogitation.com/2018/12/'> December 2018 </option>
	<option value='https://deepcogitation.com/2018/09/'> September 2018 </option>
	<option value='https://deepcogitation.com/2018/06/'> June 2018 </option>
	<option value='https://deepcogitation.com/2018/05/'> May 2018 </option>
	<option value='https://deepcogitation.com/2018/04/'> April 2018 </option>
	<option value='https://deepcogitation.com/2018/03/'> March 2018 </option>
	<option value='https://deepcogitation.com/2018/02/'> February 2018 </option>
	<option value='https://deepcogitation.com/2018/01/'> January 2018 </option>
	<option value='https://deepcogitation.com/2017/11/'> November 2017 </option>
	<option value='https://deepcogitation.com/2017/10/'> October 2017 </option>
	<option value='https://deepcogitation.com/2017/09/'> September 2017 </option>
	<option value='https://deepcogitation.com/2017/08/'> August 2017 </option>
	<option value='https://deepcogitation.com/2017/06/'> June 2017 </option>
	<option value='https://deepcogitation.com/2017/02/'> February 2017 </option>
	<option value='https://deepcogitation.com/2017/01/'> January 2017 </option>
	<option value='https://deepcogitation.com/2016/12/'> December 2016 </option>
	<option value='https://deepcogitation.com/2016/11/'> November 2016 </option>
	<option value='https://deepcogitation.com/2016/10/'> October 2016 </option>
	<option value='https://deepcogitation.com/2016/09/'> September 2016 </option>
	<option value='https://deepcogitation.com/2016/08/'> August 2016 </option>
	<option value='https://deepcogitation.com/2016/07/'> July 2016 </option>
	<option value='https://deepcogitation.com/2016/06/'> June 2016 </option>
	<option value='https://deepcogitation.com/2016/05/'> May 2016 </option>
	<option value='https://deepcogitation.com/2016/04/'> April 2016 </option>
	<option value='https://deepcogitation.com/2016/01/'> January 2016 </option>
	<option value='https://deepcogitation.com/2015/12/'> December 2015 </option>
	<option value='https://deepcogitation.com/2015/11/'> November 2015 </option>
	<option value='https://deepcogitation.com/2015/10/'> October 2015 </option>
	<option value='https://deepcogitation.com/2015/09/'> September 2015 </option>
	<option value='https://deepcogitation.com/2015/08/'> August 2015 </option>
	<option value='https://deepcogitation.com/2015/07/'> July 2015 </option>
	<option value='https://deepcogitation.com/2015/06/'> June 2015 </option>
	<option value='https://deepcogitation.com/2015/05/'> May 2015 </option>
	<option value='https://deepcogitation.com/2015/04/'> April 2015 </option>
	<option value='https://deepcogitation.com/2015/03/'> March 2015 </option>
	<option value='https://deepcogitation.com/2015/01/'> January 2015 </option>
	<option value='https://deepcogitation.com/2014/12/'> December 2014 </option>
	<option value='https://deepcogitation.com/2014/11/'> November 2014 </option>
	<option value='https://deepcogitation.com/2014/10/'> October 2014 </option>
	<option value='https://deepcogitation.com/2014/09/'> September 2014 </option>
	<option value='https://deepcogitation.com/2014/08/'> August 2014 </option>
	<option value='https://deepcogitation.com/2014/07/'> July 2014 </option>
	<option value='https://deepcogitation.com/2014/06/'> June 2014 </option>
	<option value='https://deepcogitation.com/2014/05/'> May 2014 </option>
	<option value='https://deepcogitation.com/2014/04/'> April 2014 </option>
	<option value='https://deepcogitation.com/2014/03/'> March 2014 </option>
	<option value='https://deepcogitation.com/2014/02/'> February 2014 </option>
	<option value='https://deepcogitation.com/2014/01/'> January 2014 </option>
	<option value='https://deepcogitation.com/2013/12/'> December 2013 </option>
	<option value='https://deepcogitation.com/2013/11/'> November 2013 </option>
	<option value='https://deepcogitation.com/2013/10/'> October 2013 </option>
	<option value='https://deepcogitation.com/2013/09/'> September 2013 </option>
	<option value='https://deepcogitation.com/2013/08/'> August 2013 </option>
	<option value='https://deepcogitation.com/2013/07/'> July 2013 </option>
	<option value='https://deepcogitation.com/2013/06/'> June 2013 </option>
	<option value='https://deepcogitation.com/2013/05/'> May 2013 </option>
	<option value='https://deepcogitation.com/2013/04/'> April 2013 </option>
	<option value='https://deepcogitation.com/2013/03/'> March 2013 </option>
	<option value='https://deepcogitation.com/2013/02/'> February 2013 </option>
	<option value='https://deepcogitation.com/2013/01/'> January 2013 </option>
	<option value='https://deepcogitation.com/2012/12/'> December 2012 </option>
	<option value='https://deepcogitation.com/2012/11/'> November 2012 </option>
	<option value='https://deepcogitation.com/2012/10/'> October 2012 </option>
	<option value='https://deepcogitation.com/2012/09/'> September 2012 </option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-2" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>

		</aside>		</div><!-- #secondary .widget-area -->

				<div id="tertiary" class="widget-area" role="complementary">
			<aside id="linkcat-46915546" class="widget widget_links"><h1 class="widget-title">Friend Blogs</h1>
	<ul class='xoxo blogroll'>
<li><a href="https://africauncensored.online/" target="_blank">Africa Uncensored</a></li>
<li><a href="http://africommons.com/" title="Kenya, East Africa and the United States Today" target="_blank">AfriCommons Blog</a></li>
<li><a href="http://jukwaa.proboards.com" title="Jukwaa" target="_blank">Jukwaa</a></li>
<li><a href="http://www.jamiiforums.com/kenya-forums/" title="Kenya Forum on Jamii Forums" target="_blank">Kenya Forum on Jamii Forums</a></li>
<li><a href="http://kenyastockholm.com/" target="_blank">Kenya Stockholm Blog</a></li>
<li><a href="http://www.nanjalawrites.com/" target="_blank">Nanjala Writes</a></li>
<li><a href="https://www.theelephant.info/" target="_blank">The Elephant</a></li>

	</ul>
</aside>
		</div><!-- #tertiary .widget-area -->
		
	</div><!-- #main -->

	<footer id="colophon" role="contentinfo">
		<div id="site-generator">
						<a href="https://wordpress.com/?ref=footer_blog" rel="nofollow">Blog at WordPress.com.</a>
			
					</div>
	</footer><!-- #colophon -->
</div><!-- #page -->

<!--  -->
	<div style="display:none">
	<div class="grofile-hash-map-e21ce7d4fa9290d645b5419b9731f842">
	</div>
	<div class="grofile-hash-map-30a766b0476aee54c8fba7fed01f40bc">
	</div>
	</div>
<script>
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/deepcogitationdotcom.wordpress.com\/public.api\/connect\/?action=request&domain=deepcogitation.com","logoutURL":"https:\/\/deepcogitationdotcom.wordpress.com\/wp-login.php?action=logout&_wpnonce=156c3b7e73","homeURL":"https:\/\/deepcogitation.com\/","postID":"10494","gravDefault":"mystery","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1573483029j'></script>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/deepcogitation.com\/2020\/03\/09\/we-will-never-forget-josiah-mwangi-kariuki-jm\/":10494};
	</script>
							<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			<div id="fb-root"></div>
			<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
			<script>
			jQuery( document.body ).on( 'post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
			<script type="text/javascript">
			jQuery( document ).ready( function() {
				jQuery.getScript( 'https://platform.linkedin.com/in.js?async=true', function success() {
					IN.init();
				});
			});
			jQuery( document.body ).on( 'post-load', function() {
				if ( typeof IN != 'undefined' )
					IN.parse();
			});
			</script>	<div id="sharing_email" style="display: none;">
		<form action="/2020/03/09/we-will-never-forget-josiah-mwangi-kariuki-jm/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<div
				class="g-recaptcha"
				data-sitekey="6LcmyE0UAAAAALID28yVNg7pFCodGaArJzHitez_"
				data-theme="light"
				data-type="image"
				data-tabindex="0"></div>
			<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en" async></script>
			
			<img style="float: right; display: none" class="loading" src="https://s2.wp.com/wp-content/mu-plugins/post-flair/sharing/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<link rel='stylesheet' id='all-css-0-3' href='https://s2.wp.com/wp-content/plugins/gutenberg-blocks/jetpack-layout-grid/blocks/front.css?m=1576278967h&cssminify=yes' type='text/css' media='all' />
<script>
var comment_like_text = {"loading":"Loading..."};
</script>
<script>
var actionbardata = {"siteID":"40071655","siteName":"The Real Deal","siteURL":"https:\/\/deepcogitation.com","icon":"<img alt='' src='https:\/\/deepcogitationdotcom.files.wordpress.com\/2017\/10\/cropped-sankofa-dc.png?w=50' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/itheme2","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/wordpress.com\/log-in?redirect_to=https%3A%2F%2Fdeepcogitation.com%2F2020%2F03%2F09%2Fwe-will-never-forget-josiah-mwangi-kariuki-jm%2F&signup_flow=account&domain=deepcogitation.com","themeURL":"","xhrURL":"https:\/\/deepcogitation.com\/wp-admin\/admin-ajax.php","nonce":"4639d14e5f","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"f48e6bb75d\" \/>","referer":"https:\/\/deepcogitation.com\/2020\/03\/09\/we-will-never-forget-josiah-mwangi-kariuki-jm\/","canFollow":"1","feedID":"53037145","statusMessage":"","customizeLink":"https:\/\/deepcogitationdotcom.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Fdeepcogitationdotcom.wordpress.com%2F2020%2F03%2F09%2Fwe-will-never-forget-josiah-mwangi-kariuki-jm%2F","postID":"10494","shortlink":"https:\/\/wp.me\/p2I8t1-2Jg","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/deepcogitation.com\/10494","statsLink":"https:\/\/wordpress.com\/stats\/post\/10494\/deepcogitation.com","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: iTheme2","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/read\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in Reader","viewReadPost":"View post in Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 1,021 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/wordpress.com\/log-in?redirect_to=https%3A%2F%2Fdeepcogitation.com%2F2020%2F03%2F09%2Fwe-will-never-forget-josiah-mwangi-kariuki-jm%2F&signup_flow=account&domain=deepcogitation.com\">Log in now.<\/a>","stats":"Stats"}};
</script>
<script>
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJydUtlSwzAM/CEc96LQB4ZPYRxbaZX4wrITytdjQ9LpkSkDL7ZGq11pZfPBM+lsBBt5S1xBjxL8R9XSA7+EvKNogEjsYQZt3xOE43hVaHuE4deyFqIXsmMBCD9vVE1iXqc9WuIaOyCeSQkOwioNYSpGK3VSGSzDI0Xeg1UuFMg7fWxQ68qgvdaehJukNSOMwEBhRLsfW/LN02Kx3Wx3vNYuJ7N3YjmU3dhlxt7ZvNIZk1PsZ+62GKg5DejvmbwhXST+7wD6IiJdslG5wY42vk+6BufWOo0RwOvj3DLPPAiVcVaLwI2gCCFHzPUQAhaxU+6PCjHkX3KzgXOSjOhsIZ2ie9UdkoHI1tWCv2WnvHHB3Kkvr88aLTBwOoiQdzzdmfRqXpaPz6vderlZLdsvzL07Ww=='></script>
<script type='text/javascript'>
( 'fetch' in window ) || document.write( '<script src="https://s0.wp.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?m=1573572739h&#038;ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://s1.wp.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?m=1540208548h&#038;ver=3.26.0-0"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://s1.wp.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?m=1550600082h&#038;ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://s2.wp.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?m=1540208548h&#038;ver=2.0.2"></scr' + 'ipt>' );
</script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>		<iframe src='https://widgets.wp.com/likes/master.html?ver=20190321#ver=20190321' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
<script src="//stats.wp.com/w.js?61" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'40071655','blog_tz':'3','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'40071655','v':'wpcom','tz':'3','user_id':'0','post':'10494','subd':'deepcogitationdotcom'}]);
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1TaVhzUzFMbjdWNHpwZGhTayxPSUFCMGNrd29+Smw0TDhnZmRTK0hlRi9QSGh6bi9GXVhBJWIlZlR5U1JMLU8/MkNtblkvY1dlLExWJiZLREo3ZE40MDBtNlpnMFh1U0swX1slZ3YxdTNZTkZ3WndRTkxWfm0yJVZtMWZVcEp5WDE/MjhZJms9eC5Bcy42N2lVMFtXTTMyYWFZUFluYUxIb1NIMTVbVzRjUnRsbThhQWQ9LzU3eGhmXXdtNXlaYUhrQV8uXThyZmpOdS9Ka0JJTFMrK2MzPzdEdyxJbFQxeWRfbUtHeXpNVWN0c1RTSXlbXVVWLGJdMSxTJTc0Ny9ISG9nMFpOV3FQM2p2a3BTbkhsTmZFeEQ5eGg2SE0lY2N2SklBRVlvTQ=='}]);
_stq.push([ 'clickTrackerInit', '40071655', '10494' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script>
</body>
</html>